الزامات

برای اجرای وردپرس توصیه می کنیم هاست شما پشتیبانی کند:

  • PHP نگارش 7.4 یا بالاتر.
  • MySQL نگارش 5.7 or بزرگتر یا MariaDB نگارش 10.3 یا بزرگتر.
  • پشتیبانی HTTPS

واقعا همینطور است. توصیه می کنیم Apache or Nginx as the قوی ترین و کاربردی ترین سرور برای اجرای وردپرس است، اما هر سروری که از PHP و MySQL پشتیبانی می کند این کار را انجام خواهد داد. با این اوصاف، ما نمی توانیم هر محیط ممکن را آزمایش کنیم و هر یک از میزبان ها در صفحه میزبانی ما موارد فوق و موارد دیگر را بدون مشکل پشتیبانی می کند.

برای جزئیات افزونه PHP پیشنهادی، راهنمای میزبان را مشاهده نمایید.

توجه: اگر در یک محیط قدیمی هستید که فقط نسخه های قدیمی PHP یا MySQL دارید، وردپرس با PHP نیز کار می کند. 7.0+ و MySQL 5.0+, اما این نسخه ها به پایان زندگی رسمی رسیده اند و به همین ترتیب ممکن است سایت شما را در معرض آسیب پذیری های امنیتی قرار دهد.

بپرسید

در اینجا نامه ای وجود دارد که می توانید برای میزبان خود ارسال کنید. کپی و پیست کنید!

من علاقه مند به اجرای وردپرس منبع باز <https://wordpress.org/> نرم افزار وب و می خواستم بدانم که آیا حساب من از موارد زیر پشتیبانی می کند:

  • PHP 7.4 یا بیشتر
  • MySQL 5.7 یا بالاتر یا MariaDB 10.3 یا بیشتر
  • انجین‌اکس یا آپاچی با ماژول mod_rewrite
  • پشتیبانی از HTTPS

با سپاس!

لازم نیست، اما برای امنیت بهتر توصیه می شود

هاست زمانی ایمن تر است که برنامه های PHP مانند وردپرس با استفاده از نام کاربری حساب شما به جای نام کاربری مشترک پیش فرض سرور اجرا شوند. از میزبان احتمالی خود بپرسید که چه اقداماتی را برای اطمینان از امنیت حساب شما انجام می دهد.